FAQ

Frequently Asked Questions

What devices work with Acceler8?

Acceler8 is compatible with iPhone and iPad devices only. Requires iOS 9.0 or later. Optional hardware scanning devices sold here.

 


Return to FAQ